Some users cannot change their passwords
Incident Report for Ymonitor by Sentia
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 16:26 CET
Investigating
We are currently investigating this issue.
Posted Nov 16, 2020 - 15:02 CET
This incident affected: ymonitor.nl.